Special attacks delay

Face-rippin fun.

Moderator: Forum Administrators

Post Reply
Acvodad
Posts: 18
Joined: Mon Jan 26, 2015 8:31 am

Special attacks delay

Post by Acvodad » Wed Mar 11, 2015 4:25 am

Hi all cat!

I'm having trouble, more so lately, with delay on my special attacks. It is most notably during Berserk. This prevents me from getting all the attacks(3 x HT FB) in that should be possible during Berserk. If I watch my action bars during Berserk, I can see that a specific button activates after I hit it. But it just sits there and about 0.2-0.4 seconds later it is used. I would say it happens about 70% of the time.

Not sure if this is a problem with my ISP or if it's the game messing with me. Anyone else has or had this issue?

B R
Acvodad

User avatar
Kraineth
Revered
Posts: 331
Joined: Sun Apr 07, 2013 4:26 am
Contact:

Re: Special attacks delay

Post by Kraineth » Wed Mar 11, 2015 5:21 am

The most obvious culprit would probably be latency, unless of you are spamming the keybinds for those spells. WoW has a decent spell queuing system to account for latency.

The only other thing that comes to mind is that, by default spells are only cast when you actually lift up the key, instead if pressing them down. The default UI has a checkbox under the "combat" tab that changes the behavior so that the spell is cast when the key is pressed down instead.

Most action bar addons/UI's also have their own settings, because the blizzard checkbox tends to not work with addons for some reason.

Acvodad
Posts: 18
Joined: Mon Jan 26, 2015 8:31 am

Re: Special attacks delay

Post by Acvodad » Wed Mar 11, 2015 7:52 am

During Berserk I tend to mash my buttons. I've tried being gentel but still same problem. Feels very random.

I use the default option for when keys are activated. To me this feels the best. Because if I 'regret' my button press I can just keep holding the key and hit a different one. (e.g I get a CC and want to throw Thrash rather than what button I just hit)

I'll check my latency next time.

TheLOOGE
Honored
Posts: 161
Joined: Mon Oct 15, 2012 12:20 am

Re: Special attacks delay

Post by TheLOOGE » Wed Mar 11, 2015 10:22 am

Not sure if this would have anything to do with it or not, but it's worth looking into:

Check your System > Advanced settings from the Game Menu. Look for "Reduce Input Lag" and make sure it's set to "Enabled" and not "Disabled." I can tell you from personal experience when this puppy is ever Disabled for whatever reason, I notice it big time. There's always that obnoxious, ever-so-subtle delay between me hitting my buttons and the actions occurring on my screen and most of this time, this is the culprit.

Let me know if this helps.

Acvodad
Posts: 18
Joined: Mon Jan 26, 2015 8:31 am

Re: Special attacks delay

Post by Acvodad » Fri Mar 13, 2015 3:55 am

It was already enabled. : (

Tried disabling. no change. As it is now; I have to put Rip up then Shred a few times then Berserk. Instead of just Berserking right after Rip.

R I P D P S

Nayni
Revered
Posts: 202
Joined: Sat Oct 18, 2014 4:51 pm

Re: Special attacks delay

Post by Nayni » Fri Mar 13, 2015 10:37 am

Turn on the use ability on keydown, instead of keyup.
Can't remember where it is in the standard ui and can't check it atm but it's probably somewhere under combat or controls.

For addons like Bartender there's a specific option in the settings aswell.
Image
Naeyni | Kazzak EU

Bagama
Posts: 2
Joined: Fri Mar 13, 2015 12:26 pm

Re: Special attacks delay

Post by Bagama » Fri Mar 13, 2015 12:35 pm

I have the same problem here. Playing from Russia. It started on 03.10.2015. From time to time it feels like interface is freezing for 0.2-0.3 sec.
I did the tracert to my server and I have 0 losses, but one thing that I noticed: my usual ping is 110-120ms, but whet it started my global ping is jumping back and forht 110-180-110-150-110.

Zenomni
Posts: 15
Joined: Sat Jan 31, 2015 12:37 pm

Re: Special attacks delay

Post by Zenomni » Sat Mar 14, 2015 3:56 pm

Recently i have noticed the same thing i have about 23ms but since a week or 2 the servers seem laggy with the occasional screen freeze. I think this is more of a blizzard problem then anything else.

User avatar
Sibylle
Revered
Posts: 477
Joined: Thu Jan 05, 2012 6:51 am
Location: Ireland

Re: Special attacks delay

Post by Sibylle » Sun Mar 15, 2015 4:07 am

Zenomni wrote:Recently i have noticed the same thing i have about 23ms but since a week or 2 the servers seem laggy with the occasional screen freeze. I think this is more of a blizzard problem then anything else.
Yup, same here.
-Sibylle

"Not a shred of evidence exists in favor of the idea that life is serious." (Brendan Gill)

zedinsky
Posts: 17
Joined: Sun Jan 11, 2015 7:39 pm

Re: Special attacks delay

Post by zedinsky » Sat Apr 04, 2015 9:19 pm

Are you guys still experiencing this? I've tried everything on this thread but still having major issues.

Post Reply